Les membres ayant 30 points peuvent parler sur les canaux annonces, projets et hs du chat.

Forum Casio - Discussions


Index du Forum » Discussions » System ERROR des que j'allume ma graph 90+E
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

System ERROR des que j'allume ma graph 90+E

Posté le 28/05/2021 08:17

Alors
Je faisais un projet avec gint, et ca a crash
Et la je peux meme plus entrer dans le menu(la calto me lache un
System ERROR
REBOOT [EXIT]
INITIALIZE [EXE]
ADDRESS(R)
TARGET=5290C546
PC=8C15FFB8
Comment je peux faire un reset au moins...


Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 28/05/2021 08:25 | #


Habituellement RESET au dos résoud ces problèmes, sinon enlever les piles, démarrer avec le câble USB branché, ou autres trucs.

Si tu peux trouver le problème dans ton add-in on peut peut-être ajouter une protection aussi.
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 28/05/2021 08:31 | #


J'ai essayé le RESET, et toujours le meme probleme
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 28/05/2021 08:35 | #


Donc en termes de System ERROR au démarrage, j'ai dû en avoir 10-20, un truc comme ça. La majorité il suffit de RESET. Tu peux aussi essayer de retirer les piles pensant plusieurs minutes le temps que la RAM se vide (elle se maintient un bon moment même sans piles). Accepter le reboot du System ERROR peut aussi marcher. Essentiellement c'est une affaire de réinitialiser le plus de choses possibles jusqu'à ce que ça marche.

Est-ce que tu as fait des choses exotiques/instables pour mériter ça ?
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 28/05/2021 08:40 | #


Non (a part le fait que j'ai debrancé l'usb avant l'init mais ca ma jamais posé de problemes)
Bon voici les evenements
J'envoye mon code, et quand j'exit, le logo a l'air corompu
Plus d'addins externes
J'essaye de rebrancher l'USB, mais ca prend beacoup trop de temps pour s'init
Je debranche
*System ERROR*
Bon j'essaye de retirer les piles je reviens a 16h(j'ai cours la)
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 28/05/2021 08:50 | #


Tu l'as fait souvent débrancher le câble USB ? Perso je n'ai jamais osé (sauf une fois où fxlink a interrompu le transfert USB, ce qui n'est plus possible maintenant), tout ce qui trait au système de fichiers me paraît trop dangereux. Toutes les Graph 35+E II et Graph 90+E que j'ai vu bricker depuis quelques années avaient un problème ou un autre sur le fs.

S'il n'y a plus d'add-ins externes c'est quasiment toujours parce que la recherche de \\fls0\*.g3a a échoué. Une raison courante c'est si un add-in ouvre trop de fichiers et oublie de les fermer. Mais en tous cas c'est une opération sur les fichiers qui est faite normalement à la fin du transfert, ce qui suggère que LINK n'a pas réussi à faire ce qu'il voulait (ce qui peut aussi être causé par l'add-in, eg. certaines versions initiales du driver USB de gint faisaient planter LINK sur une System ERROR).

Pareil pour l'initialisation du transfert USB, c'est définitivement un truc en rapport avec le système de fichiers.
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 28/05/2021 16:50 | #


Non le projet n'utilisais meme pas les fichiers(ni l'USB aussi)
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 28/05/2021 16:52 | #


Compte tenu des informations disponibles, personnellement je me méfierais beaucoup de débrancher le câble dans LINK (si c'est bien ça que tu voulais dire).
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 28/05/2021 18:26 | #


Je peux aller dans le mode exam mais quand je retire tous les fichiers(meme ceux dans @MainMem), ca bloque toujours dans le mode normal...

Ajouté le 28/05/2021 à 19:06 :
J'ai essayé d'update l'OS mais rien.
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 28/05/2021 20:37 | #


Est-ce que tu peux ouvrir le menu secret avec OPTN+EXP+AC/ON, 5, 9, 6, 3 ; ensuite File System, Fugue API, et Logical Format ? Si ça ne marche pas, pareil mais LowLevel Format à la dernière étape ?
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 28/05/2021 21:20 | #


Le second marche, mais ca veut toujours pas boot
Le premier me donne une erreur de format, et le second le fait correctement
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 28/05/2021 21:20 | #


Gné ? Et la connexion USB (démarrer en branchant le câble) tu ne l'atteins pas je suppose ?
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 28/05/2021 21:25 | #


Oui
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 28/05/2021 21:30 | #


T'es plus loquace que ça d'habitude, les détails sont vraiment importants ici j'ai besoin de savoir si chaque chose marche, ce que tu vois, etc. Surtout qu'il n'y a pas 100 astuces :x
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 28/05/2021 21:59 | #


Alors
Quand je branche le cable USB, la calto juste reset, et c'est tout

Ajouté le 29/05/2021 à 10:49 :
SOLUTION:
Aller dans le Diagnostic Mode(OPTN+EXP+AC, F1, 9, -)
Ca clear la memoire principale, apres ca faut reboot et c'est censé marcher
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 29/05/2021 10:50 | #


Ouf ! Tu as récupéré la calto du coup ? o_o

C'est la première fois que je vois un problème de ce type, où la mémoire principale est en faute. Merci pour l'astuce, elle sera suggérée aux prochains qui ont le même problème que toi.

Du coup ça confirme que c'est LINK qui a foiré, vu que gint ne touche pas à la mémoire principale. Ne débranche pas le câble la prochaine fois ^^"
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 29/05/2021 13:42 | #


bon
bizzarement, bien que le code n'accede pas a la lecture du fichier, LINK foire toujours apres que je lance le programme (je peux bien sur reset la memoire principale, mais bon)
EDIT: Yare yare dawa...
J'ai run l'addin, je suis allé dans memoire et j'ai décidé de voir la zone des 16MB
Ca a freeze, j'ai du retirer les piles, et quand ca a boot, la calto indiquait que la mémoire était clear, et tout a l'air de bien aller
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 29/05/2021 17:07 | #


Hmm est-ce que tu utilises l'USB dans ton add-in ? C'est la seule chose que j'imagine pouvoir interférer avec LINK.
Loieducode Hors ligne Membre Points: 105 Défis: 0 Message

Citer : Posté le 29/05/2021 17:13 | #


Non, meme pas
J'ai beacoup trop de projets, nyohoho!
Lephenixnoir En ligne Administrateur Points: 20113 Défis: 143 Message

Citer : Posté le 29/05/2021 17:15 | #


Alors j'ai aucune idée. On espère que ça va passer tout seul x)

LienAjouter une imageAjouter une vidéoAjouter un lien vers un profilAjouter du codeCiterAjouter un spoiler(texte affichable/masquable par un clic)Ajouter une barre de progressionItaliqueGrasSoulignéAfficher du texte barréCentréJustifiéPlus petitPlus grandPlus de smileys !
Cliquez pour épingler Cliquez pour détacher Cliquez pour fermer
Alignement de l'image: Redimensionnement de l'image (en pixel):
Afficher la liste des membres
:bow: :cool: :good: :love: ^^
:omg: :fusil: :aie: :argh: :mdr:
:boulet2: :thx: :champ: :whistle: :bounce:
valider
 :)  ;)  :D  :p
 :lol:  8)  :(  :@
 0_0  :oops:  :grr:  :E
 :O  :sry:  :mmm:  :waza:
 :'(  :here:  ^^  >:)

Σ π θ ± α β γ δ Δ σ λ
Veuillez donner la réponse en chiffre
Vous devez activer le Javascript dans votre navigateur pour pouvoir valider ce formulaire.

Si vous n'avez pas volontairement désactivé cette fonctionnalité de votre navigateur, il s'agit probablement d'un bug : contactez l'équipe de Planète Casio.

Planète Casio v42 © créé par Neuronix et Muelsaco 2004 - 2021 | Il y a 57 connectés | Nous contacter | Qui sommes-nous ? | Licences et remerciements

Planète Casio est un site communautaire non affilié à Casio. Toute reproduction de Planète Casio, même partielle, est interdite.
Les programmes et autres publications présentes sur Planète Casio restent la propriété de leurs auteurs et peuvent être soumis à des licences ou copyrights.
CASIO est une marque déposée par CASIO Computer Co., Ltd