Les membres ayant 30 points peuvent parler sur les canaux annonces, projets et hs du chat.
La shoutbox n'est pas chargée par défaut pour des raisons de performances. Cliquez pour charger.

Forum Casio - Discussions


Index du Forum » Discussions » fx-9750GIII Storage Memory Crash
Calcloverhk Hors ligne Membre Points: 333 Défis: 10 Message

fx-9750GIII Storage Memory Crash

Posté le 26/10/2020 10:10

Updated in 2023-12-7 UTC+8

Introduction
In August 2020, I encountered the problem on my fx-9750GIII where I couldn't use my storage memory. Later, I found that a file with impossible name "僂ASSE.g1m" appeared in my calculator stoarge and couldn't delete it in any available ways. After investigation it's confirmed that this file was originally "-CASSE.g1m" from Calcraft. The reason of having a Chinese character is that the hex code of "僂" is the combination of the hex codes of "-" and "C".

Affected models
Possibly all USB Power Graphic 3 models
- fx-9750GIII: CalcLoverHK, PhantomOverrideAlpha, laomo, 0070, zhuchaokn
- fx-9860GIII: yukki410
- Graph 35+E II: yet to be seen

Characteristics
- Unable to modify the storage memory (even "Initialize All" won't work)
- LINK app shows error "Data conversion failed."
- Windows reports error 0X8007045D (I/O device error) when attempting to modify the storage content
- (Uncertain, happened once) A file with impossible name (e.g. 僂ASSE.g1m)

Possible procedures
1. Install C.Basic for FX (important as while it's possibly the main cause, it's also used to execute the workaround syscall below)
2. Create a new program file in SMEM mode and save it without typing anything, then re-open the file OR open an existing file in SMEM mode
3. Type something randomly and delete what you've exactly typed (even typing and then deleting a single letter works, just make sure the final modified file is exactly the same as the original one)
4. Save the file by pressing [EXIT]
5. The moment when you get a "Can't delete file" error pop-up with error code -6 is where this bug is triggered

At first it seems like nothing happened after the error, but as the time passes under normal use, C.Basic starts to pop up the same error more frequently and eventually even a modified program with a single letter added can't be saved.

Reasons
Deducing from the error description ("Can't delete file"), it appears that C.Basic saves a file by deleting the original file first and creating another one with exactly the same content as the modified one. If there is no actual change in the latter one however, C.Basic may confuse between both files and thus being unable to delete the proper file, while forgetting to change the Bfile status from "file opened" state to "ready" state.

However, such problem also appears in other users' GIII calculators without C.Basic, and the reasons for them are unclear.

Workaround
Warning! This method can only be used on the USB Power Graphic 3 models!
Kudos to yukki410 for discovering this method!
Execute Syscall(0x205) in C.Basic and restart the calculator.

Edit (2023-12-7):
I did more tests on this bug after Sentaro21's return on C.Basic development. Unfortunately, the SMEM on my fx-9750GIII is now permanently unusable without C.Basic after initializaing. Somehow it successfully deleted the whole memory while keeping the SMEM in the locked state. Nevertheless, it confirmed a few things.

> This bug can happen even under C.Basic's default settings.
> You may notice a significantly slower speed of saving program while repeating the procedures.
> Suprisingly Syscall(0x205) becomes one of the main causes of this bug. If you manage to trigger the bug using the workaround/still fail to access SMEM after doing it, DO NOT initialize the whole calculator and keep it as is. C.Basic is probably your last resort to dodge this problem.

If you have any other method to solve this problem, feel free to post it here! Thanks for your help and also @Lephenixnoir @Yatis for helping me tackle the problem ever since the encounter of this bug


Précédente 1, 2, 3, 4, 5, 6, 7 Suivante
Mexischillax Hors ligne Membre Points: 17 Défis: 0 Message

Citer : Posté le 16/09/2023 04:39 | #


@Calcloverhk
how did you fix this error? It has been many months now and I have tried everything I know [I do not know much hehe]
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 16/09/2023 04:45 | #


I saw a chinese web where it was fixed by a cbasic command thing, but im not really sure what that is....
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 19/09/2023 08:31 | #


I have found something! when I enter diagnostic mode then press f1 i get to this CY837A Main place. I have tried the things on that menu and I dont think they work...
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 22/09/2023 22:30 | #


been a while again, have you had any time to look into the problem lephoenix from memory, i think it has been a bit less than two weeks since you said you had an academic paper due the week later
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 22/09/2023 23:08 | #


I would say patience, but it really has been a while. Im not sure if there is a solution to this anymore
does @user work?
Mexischillax Hors ligne Membre Points: 17 Défis: 0 Message

Citer : Posté le 22/09/2023 23:10 | #


last 4 messages were by you Fries XD I don't think there is any known solution sadly
Mexischillax Hors ligne Membre Points: 17 Défis: 0 Message

Citer : Posté le 25/09/2023 00:14 | #


Is anyone still here or is this problem unsolvable
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 25/09/2023 00:38 | #


I think this problem has been abandond or scraped
everyone who did fix it has cbasic, we (I) don't...
Slyvtt Hors ligne Maître du Puzzle Points: 2309 Défis: 17 Message

Citer : Posté le 25/09/2023 07:53 | #


Guys, this is my understanding of the issue.
For any reason, the Bfile-based filesystem has been "corrupted" by an addin, meaning a file that has been opened has not been correctly closed at the end (crash ?) of the addin.
This opened file acts as a lock and does not allow to interact normally with the filesystem. Hence all operations from a remote PC are now impossible (read/write/delete files especially).
So far the only trick to solve that issue is through the addin C-Basic that should be already present on the calculator BEFORE the appearance of such an issue (because, as you may imagine, after it is too late as it is impossible to copy that addin on the machine).
Then, if available, the trick consists in making a very short program in C-Basic that initiate a call to the "magical" 0x205 syscall. This seems to reset all the opened files and solve the issue.
To our knowledge, there is no other trick to solve this problem (at least documented within the community).

---
Maybe should you try to reinstall completely the OS (if it works), but this is without any guarantee that it will work at the end of the process.
There are only 10 types of people in the world: Those who understand binary, and those who don't ...
Lephenixnoir Hors ligne Administrateur Points: 24232 Défis: 170 Message

Citer : Posté le 25/09/2023 08:06 | #


I'm still on it. There is on thing we haven't tried an that is to reformat the filesystem. There is an option for this in the test menu. However, the key combination to open the test menu doesn't work on the G-III; it was probably changed. I have to do some reverse-engineering to try and find it. It's taking a bit of time because my tools need an update as well. Sorry for the slow progress, but be assured I'm not giving this up yet.
Mon graphe (11 Avril): ((Rogue Life || HH2) ; PythonExtra ; serial gint ; Boson X ; passe gint 3 ; ...) || (shoutbox v5 ; v5)
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 25/09/2023 08:34 | #


I have tried installing a new OS, this did not solve it. Thanks lephen, means a lot
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 25/09/2023 08:36 | #


As soon as this error is solved, i am adding the Cbasic thing which apparently can do a lotta thing fixing
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 01/10/2023 09:41 | #


hmm, any progress?
Mexischillax Hors ligne Membre Points: 17 Défis: 0 Message

Citer : Posté le 02/10/2023 05:27 | #


doesn't look like it Fries, gotta keep waitin
Lephenixnoir Hors ligne Administrateur Points: 24232 Défis: 170 Message

Citer : Posté le 05/10/2023 11:28 | #


Slowly because of work. Still on top of my list, I've just been away from the forum for a short while now. (Feel free to ping)
Mon graphe (11 Avril): ((Rogue Life || HH2) ; PythonExtra ; serial gint ; Boson X ; passe gint 3 ; ...) || (shoutbox v5 ; v5)
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 06/10/2023 02:53 | #


any progress lately lephen?
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 06/10/2023 02:54 | #


ah, ok
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 11/10/2023 01:55 | #


any progress lately
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 11/10/2023 01:57 | #


after i do the optn thing i pressed f1 and gotten into a menu place. i have tried everything on the menu, nothing works
Lephenixnoir Hors ligne Administrateur Points: 24232 Défis: 170 Message

Citer : Posté le 11/10/2023 07:31 | #


Yeah this is the test menu, which doesn't have any interesting feature, except for a bunch of info. There has been progress internally - to search the code I'm using a tool that needed better function exploration, and I implemented most of that. (Sorry it's not the fastest method, I'm trying my best to get many things done in limited time)
Mon graphe (11 Avril): ((Rogue Life || HH2) ; PythonExtra ; serial gint ; Boson X ; passe gint 3 ; ...) || (shoutbox v5 ; v5)
Fries Hors ligne Membre Points: 88 Défis: 0 Message

Citer : Posté le 12/10/2023 09:25 | #


ok, so is that it for the test menu or is there still the four numbers to get into a more... menu menu
Précédente 1, 2, 3, 4, 5, 6, 7 Suivante

LienAjouter une imageAjouter une vidéoAjouter un lien vers un profilAjouter du codeCiterAjouter un spoiler(texte affichable/masquable par un clic)Ajouter une barre de progressionItaliqueGrasSoulignéAfficher du texte barréCentréJustifiéPlus petitPlus grandPlus de smileys !
Cliquez pour épingler Cliquez pour détacher Cliquez pour fermer
Alignement de l'image: Redimensionnement de l'image (en pixel):
Afficher la liste des membres
:bow: :cool: :good: :love: ^^
:omg: :fusil: :aie: :argh: :mdr:
:boulet2: :thx: :champ: :whistle: :bounce:
valider
 :)  ;)  :D  :p
 :lol:  8)  :(  :@
 0_0  :oops:  :grr:  :E
 :O  :sry:  :mmm:  :waza:
 :'(  :here:  ^^  >:)

Σ π θ ± α β γ δ Δ σ λ
Veuillez donner la réponse en chiffre
Vous devez activer le Javascript dans votre navigateur pour pouvoir valider ce formulaire.

Si vous n'avez pas volontairement désactivé cette fonctionnalité de votre navigateur, il s'agit probablement d'un bug : contactez l'équipe de Planète Casio.

Planète Casio v4.3 © créé par Neuronix et Muelsaco 2004 - 2024 | Il y a 29 connectés | Nous contacter | Qui sommes-nous ? | Licences et remerciements

Planète Casio est un site communautaire non affilié à Casio. Toute reproduction de Planète Casio, même partielle, est interdite.
Les programmes et autres publications présentes sur Planète Casio restent la propriété de leurs auteurs et peuvent être soumis à des licences ou copyrights.
CASIO est une marque déposée par CASIO Computer Co., Ltd