Les membres ayant 30 points peuvent parler sur les canaux annonces, projets et hs du chat.
Menu
Liste des logiciels
Nom Date
Libs Python Graph 35+E II et Graph 90+E
SDK G85 - EasyInput
SDK G85 - Memory and Files access
SDK G85 - Easy Coding
SDK G85 - Easy grayscales
SDK G85 - GrayScreenshotLib
SDK G85 - MonochromeLib
Lua - Tile Motor


Visiteurs :
Si vous souhaitez soumettre un logiciel veuillez prendre contact avec un administrateur seuls à pouvoir ajouter des logiciels par mesure de sécurité.
Logiciels >> Snippets >> SDK G85 - MonochromeLib
SDK G85 - MonochromeLib
Ajouté par :
PierrotllHors ligneAncien administrateurPoints: 5488 Défis: 41 Message
Pour les calculatrices : Graph 35+ USB, 35+E, 75, 75+, 75+E
Ajouté le : 2011-02-17 13:54
Nombre de visites de la page : 45346

Fichiers à télécharger :

¤ MonochromeLib-11-22-2011.zip 23 Ko (3069 téléchargements)

Description :

Dernière version en ligne : GitLab


MonochromeLib, qu'est ce que c'est ?
MonochromeLib est une bibliothèque de dessin pour le SDK Casio Graph 85.
Elle fournit aux développeurs des fonctions optimisées pour tracer toute sorte de choses à l'écran.
Chaque fonction de MonochromeLib est bien plus rapide que son équivalent dans fxlib.h, et elle fournit de nombreuses fonctionnalités supplémentaires.

Comment l'utiliser
Pour utiliser la bibliothèque, copiez les 2 fichiers dans le dossier de votre projet, ajoutez MonochromeLib.c à votre projet (dans la fenêtre "Files in project" dans le SDK), ajoutez #include "MonochromeLib.h" au début de votre code.
Pour n'ajouter à votre projet que les fonctions dont vous avez besoin, chaque fonction est protégée par un #ifdef, et les #define de chaque fonction sont commentés par défaut.
Pour pouvoir utiliser une fonction, il suffit d'éditer MonochromeLib.h et de décommenter les #define des fonctions que vous voulez utiliser.
/!\\ Important
Si vous rencontrez une erreur de compilation de ce type :
** L2310 (E) Undefined external symbol "_ML_pixel" referenced in "C:\\...\\CASIO\\fx-9860G SDK\\Projet\\Debug\\MonochromeLib.obj"
et que le #define de la fonction en question est bien actif dans MonochromeLib.h, alors il faut juste recompiler MonochromeLib.c
Pour cela, Utilisez la fonction Project > Rebuilt all dans le SDK. Si cela ne résoud pas le problème, supprimez le dossier Debug de votre projet, et recompilez normalement.

N'attendez plus !
Une documentation complète est maintenant fournie dans l'archive zip, en anglais et en français.

Version actuelle : 22 novembre 2011
Télécharger MonochromeLib

Commentaires :

Pages: Précédente | 1, 2, 3, 4, 5, 6, 7, 8, 9 | Suivante

LephenixnoirEn ligneAdministrateurPoints: 19535 Défis: 142 Message
Posté le 19-04-2015 à 10:53 | #
La syntaxe du break est « break », sans majuscule.
AclecHors ligneMembrePoints: 5 Défis: 0 Message
Posté le 19-04-2015 à 10:54 | #
Merci mais il me le compte aussi faux, dois-je ajouter une nouvelle librairie ?
LephenixnoirEn ligneAdministrateurPoints: 19535 Défis: 142 Message
Posté le 19-04-2015 à 10:55 | #
Non, il n'y a pas du tout besoin d'utiliser une bibliothèque ; cette commande est inscrite dans le langage lui-même.

Je vous invite à préciser votre problème (code, message d'erreur), mais sur un sujet approprié tel que celui-ci :
http://www.planet-casio.com/Fr/forums/topic12473-18-Problemes-SDK-divers-et-varies.html
AclecHors ligneMembrePoints: 5 Défis: 0 Message
Posté le 19-04-2015 à 10:57 | #
Merci de votre aide rapide, bonne journée.
DrakHors ligneRédacteurPoints: 1925 Défis: 40 Message
Posté le 31-07-2018 à 10:10 | #
Le lien GitLab est mort, par ailleurs. J'ai une grosse "404 page not found"
LephenixnoirEn ligneAdministrateurPoints: 19535 Défis: 142 Message
Posté le 31-07-2018 à 11:47 | #
Remplacé http par https et l'IP par le ndd, ça passe mieux. Sans doute le port qui a changé.
Embe_franceHors ligneMembrePoints: 20 Défis: 0 Message
Posté le 30-11-2019 à 12:45 | #
Génial merci !
PedrobzhHors ligneMembrePoints: 476 Défis: 0 Message
Posté le 23-10-2020 à 21:52 | #
ca marche sur graph 35+E II?
Shadow15510Hors ligneAdministrateurPoints: 4660 Défis: 16 Message
Posté le 23-10-2020 à 21:54 | #
Malheureusement non. Ce SDK a été conçu pour les calculatrices d'ancienne génération (Graph 85) qui avaient alors des processeurs SH3.

Du bricolage permettait cependant de l'utiliser avec les modèles monochromes SH4 (Graph 35+E), mais avec l'arrivée des calculatrice de dernière génération (Graph 35+E II) cet outil est définitivement hors course. Rectification : on peut encore s'en servir partiellement.
Dark stormEn ligneMembre d'honneurPoints: 11353 Défis: 176 Message
Posté le 23-10-2020 à 21:55 | #
Oui. Mais pas toutes les bibliothèques sont compatibles. Je te conseille vivement d'utiliser gint si tu veux une compatibilité parfaite.

Pages: Précédente | 1, 2, 3, 4, 5, 6, 7, 8, 9 | Suivante

Planète Casio v42 © créé par Neuronix et Muelsaco 2004 - 2021 | Il y a 74 connectés | Nous contacter | Qui sommes-nous ? | Licences et remerciements

Planète Casio est un site communautaire non affilié à Casio. Toute reproduction de Planète Casio, même partielle, est interdite.
Les programmes et autres publications présentes sur Planète Casio restent la propriété de leurs auteurs et peuvent être soumis à des licences ou copyrights.
CASIO est une marque déposée par CASIO Computer Co., Ltd